Apache Libcloud

Apache Libcloud Links All Clouds Together

Apache Libcloud brings interoperability among different cloud setups/providers.  It provides only single Application Programming Interface to manage various cloud resources. It fulfills the long time dream of hiding the differences among multiple cloud systems. Now developers can write applications that will run on almost all popular cloud infrastructures with great ease. It supports all popular cloud service providers like Amazon, RackSpace, Openstack, VMWare etc. There are more than 50 cloud service providers who are being supportd by Apache Libcloud now. Simply use this API to code your applications and you will go live on any sort of cloud infrastructure within minutes. It is developed in python and supports all latest python versions.

Features for Apache Libcloud

Apache Libcloud has capability to manage all important components of a public or private cloud. If we classify its capabilities, here are the cloud computing areas that are supported by Apache Libcloud.

1. Cloud Servers
2.  Block Storage
3. Object Storage
4.  Content Delivery Network (CDN)
5.  Load Balancer as a Service
6. DNS as a Service

This python API can manage Rackspace servers, Amazaon EC2, and storage like S3, swift, ceph etc. Common examples of supported Load Balancers are Elastic Load Balancer, Openstack Load Balancer, and GoGrid. It is very friendly with Amazon Route 53 and Zerigo DNS services as well. Some renowned cloud service providers are already using this API to cater the modern day cloud computing needs of their customers.

The supported python versions by this API are: Python 2.5, Python 2.6, Python 2.7 and Python 3.0 . Looking back at the history of Apache Libcloud, it was first started in 2009 as an open source project by a company called Cloudkick. Later, it joined Apache Incubator and has been under continuous development since then (2011).  Let’s see how to install and use this API on Ubuntu Linux system.

Installing and Using Apache Libcloud on Ubuntu Linux 16.04

Let’s see how to install Apache Libcloud’s stable version on Ubuntu 16.04 system. The following set of instructions should also work on any older version of Ubuntu like 15.10, 15.04 etc. First of all make sure to upgrade your system using APT.

sudo apt-get update

Once the update process complete, run following command to install pip on your system. Pip is needed to install Apache Libcould’s stable version.

sudo apt-get install python-pip

Once Pip has been installed, run following command to install Apache Libcloud.

pip install apache-libcloud

Apache Libcloud

If you already had Pip installed on your system, you can update the Pip to the latest version by using the following command.

pip install --upgrade pip

If you have old version for Pip, it should still install Apache Libcloud, but might display some warnings as shown in the following screenshot.

Apache Libcloud install

Congratulations! That’s it, the stable version for Apache Libcloud has been installed now.

Installing Development Version

Please note that stable version might be bit old, if you are looking to try or use the most recent version for Apache Libcloud, you need to use its Git repository. Here is the exact command to install the most recent version.

pip install -e git+https://git-wip-us.apache.org/repos/asf/libcloud.git@trunk#egg=apache-libcloud

Upgrading Apache Lincloud

You can upgrade the existing installation of Apache Libcloud by using the following command.

pip install --upgrade apache-libcloud

Using Apache Libcloud

Here are some of the code snippets taken from its official site which demonstrate how to code using this API. Python developers might find it straightforward and easy.

Compute Libcloud

Libcloud DNS



Apache Libcloud has gained massive popularity and some renowned companies like Rackspace, DivyCloud, Scaler, SaltStack, CloudControl etc have it in the production use. It is future of cloud computing technology, as interoperability among various cloud vendors is the demand of coming era. The installation and upgrade process for this API framework is pretty easy. Give it a try, you wouldn’t regret learning it :)

If you enjoy our article(s), Please use “Get Linuxpitstop articles by Email” option to get latest articles by email. Please like, follow and share our social network pages, we need help from esteemed visitors like yourself to keep this venture going. 



Please follow and like us:

Leave a Comment

4 − = three